Page 1 of 3 123 LastLast
Results 1 to 10 of 24

Thread: Allowed memory size of 33554432 bytes exhausted

  1. #1
    Join Date
    Nov 2007
    Posts
    25

    Default Allowed memory size of 33554432 bytes exhausted

    Hi, Im trying to use JSON and php to get data from another site, but I keep getting this error;
    Fatal error: Allowed memory size of 33554432 bytes exhausted (tried to allocate 24 bytes)

    Is there anyway I can fix this? Or do I have to look for a way to split the data in two to get it over:S?

  2. #2

    Default

    Increase the max_memory variable in your php.ini file.

  3. #3
    Join Date
    Nov 2007
    Posts
    25

    Default

    Oh, I see, great! It works, thanks=)

  4. #4
    Join Date
    Jul 2008
    Posts
    6

    Default Out of Memory

    I increased max_memory and now comes:

    Fatal error: Out of memory (allocated 262144) (tried to allocate 1029988705 bytes)

    HELP

  5. #5
    Join Date
    Sep 2008
    Location
    Orem
    Posts
    10

    Default CiviCRM and memory error

    I installed CiviCRM and got an error during the install that said my memory_limit was 32M and to increase it 64M. I went to /home/mydomain/public_html/php.ini and changed memory_limit = 32M to memory_limit = 64M

    CiviCRM still gave me the error saying my memory limit was 32M, but I went ahead with the install.

    Now when I click on CiviEvent I get an error that states

    Fatal error: Allowed memory size of 50331648 bytes exhausted (tried to allocate 7680 bytes) in /home/mydomain/public_html/drupal/modules/views/handlers/views_handler_field_url.inc on line 10

    I search the CiviCRM forum, and the Drupal forum. It looks like the recommendation is to increase the memory limit from 32M to 64M. Is there something I missed? Was there some other place I needed to make the change?

  6. #6

    Default

    I'd recommend copying your php.ini into each directory of your script.

    Some people recommend using FastCGI, personally, I don't as it causes more problems than it prevents.

  7. #7
    Join Date
    Jul 2008
    Posts
    1

    Default Fatal error: Allowed memory size exhausted

    Hi I installed Virutemart 1.1 on a Joomla 1.5.7 website, every thing is fine expect that I receive the below message when I try to export the data of 3000 products, using different export templates:

    Fatal error: Allowed memory size of 16777216 bytes exhausted (tried to allocate 87 bytes) in /home2/mysit/public_html/libraries/joomla/database/database/mysql.php on line 460
    I changed memory_limit in /.../database/php.ini to 32, 64 and eventually 100M (Originally it was 12M) but I still receive exactly the same error message.

    Any clue or help is very appreciated. :confused:
    Last edited by farhado; 10-05-2008 at 03:21 PM.

  8. #8
    Join Date
    Oct 2008
    Posts
    7

    Default Changes made to the php.ini

    Changes made to the php.ini file do not act recursively. This means that even if you change the value in the php.ini (the one directly in the public_html folder) the changes do not take effect for any script that is not directly inside of the public_html folder.

    Bluehost now has a new option inside of the PHP Config utility that is absolutely fantastic. There is an option to use one php.ini for the entire account. Simply change the value in your php.ini file that is directly inside of the public_html folder and then select that option in the PHP Config utility so that it's used for your entire account.

    Hopefully this helps you out

  9. #9
    Join Date
    Oct 2008
    Posts
    3

    Default

    ok how can I use the php utility

  10. #10
    Early Out's Avatar
    Early Out is offline Former Moderator, Still Respected
    Join Date
    Mar 2006
    Location
    Sector R
    Posts
    4,643

    Default

    Change the memory value in public_html/php.ini. Then go to Control Panel, PHP Config, and choose "PHP5 (Single php.ini)." This will cause all subdirectories to use the php.ini in your public_html directory.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •